Hi all — The Kawasaki ZZR1100 Appreciation Society

netboard

Hi all ..

Has anyone got a sump for a D engine .. The one I had repaired leaks at the oil cooler union I had welded .. I have a good C sump but it don't have the pressure relief valve and I don't know how important it is to the D engine .. There is 1 on eBay but I'll ask here first I would sooner buy from someone in the group ..cheers ..AL..

%d comments

Hi all — The Kawasaki ZZR1100 Appreciation Society

Hi all.

Low down running probs are persisting

Running quite rich.

Bikes got a full Remus on it and I'm wondering if someone's been playing with the jets in the past.

Everything has been cleaned thoroughly so I recon a full carb set up in order.

Anyone know of hand what the standard jetting is?

%d comments

    Pat McCullagh shared a link to the group: The Kawasaki ZZR1100 Appreciation Society. — The Kawasaki ZZR1100 Appreciation Society

    Only of use to our very local members but this is a 'must share' at these prices!

    Due to some late cancellations, we have a limited amount of spaces on a St. John’s Ambulance “By Bikers for Bikers” First Aid course on Sunday 14th June 2015.

    At Bromsgrove right on Junction 1 M42 from 9am until 4pm. Bring a snack or there’s a garage across the road. Tea, coffee and water are 'on tap'.

    These spaces are at a vastly reduced rate of £20 each. Further courses in the future are readily available but would be more in the region of £35 per person.

    Probably the most important aspect of the day is emphasis on ‘what to do until the ambulance arrives', probably the most critical time of all.

    The link below is old but the message is still the same. Please feel free to message me for further details.

    %d comments

      Help please guys I think my fuel pump is not working I can redline my z when... — The Kawasaki ZZR1100 Appreciation Society

      Help please guys. I think my fuel pump is not working. I can redline my z when it's stationary but when going down the road it dies at about 4k revs or 30/40 mph. It's as if the bike runs out of fuel, I can pull the clutch in and it will tick over. When I try and accelerate the bike lurches for split seconds as if a bit of fuel got through. I have cleaned the tank filters, rebuilt the tap, new hose and filter before the pump. The bike ran really well before and all I've done is take the tank off and put new bits in. Haven't touched carbs or hoses under the air filter??? Any suggestions greatly appreciated

      %d comments